Sign in to follow this  
Followers 0

2K9 Frustration

19 posts in this topic

Posted

Well fellas, That's it I've had it with MLB 2K9. This is one of the most unfriendly games I've ever attempted to play/mod. After dealing with all sorts of crashes and some really weird in game happenings (Manager suddenly has no legs from the knees on down, etc.)I'm wondering whether or not to go and get 2K10 today. Any advice will be much appreciated.

Share this post


Link to post
Share on other sites

Posted

Well fellas, That's it I've had it with MLB 2K9. This is one of the most unfriendly games I've ever attempted to play/mod. After dealing with all sorts of crashes and some really weird in game happenings (Manager suddenly has no legs from the knees on down, etc.)I'm wondering whether or not to go and get 2K10 today. Any advice will be much appreciated.

You posted this in the console forum, do you have the 360 version or the PC version? I only ask because I helped you earlier with a PC mod for 2K9.

I'm one of the few that played MLB 2K9 (PC) a lot last year and applied just about every mod that was made for it. Never had one crash or freeze. It did have many strange graphical glitches like the one you mentioned above, but nothing that ever caused it to crash on me.

As far as applying mods to the game, it is really pretty simple as all the mods go in pretty much one folder. All you're doing is really copying/pasting... and of course you should always backup your original files before you apply any mod.

While this year's effort is again far from perfect, I'm enjoying the game with all its shortcomings. Guys have made some nice mods and I've got me a good set of sliders that give me varied/challenging games. There is a PC patch in the works to fix many issues, but there is no ETA.

Share this post


Link to post
Share on other sites

Posted

Thanks for the tips. O.K. then . I'm going to uninstall, and start over one more time and see how it turns out then. I have been, and still am using the PC version w/the 1.1 patch installed.I'll let you know how it turns out. Thanks again pal!

Share this post


Link to post
Share on other sites

Posted

Thanks for the tips. O.K. then . I'm going to uninstall, and start over one more time and see how it turns out then. I have been, and still am using the PC version w/the 1.1 patch installed.I'll let you know how it turns out. Thanks again pal!

If you are going to be installing/trying out a lot of mods, you need to make a folder with some key original files in it. After you do your re-install, Backup the following found in your MLB 2K9 directory:

global.iff

All uniform files. They start with: uniform_

All stadium files. They start with: stadium_

*Before you install any mod, read its description and see what file(s) it changes... then go to your MLB 2K folder and make a backup of the original file. Will save yourself a lot of headaches in the future.

*Also, if you are crashing/freezing with just the default install of the game, it could be something else. Does your system meet the system requirements? (CPU, RAM, Video card) Do you have any programs running the background?

Share this post


Link to post
Share on other sites

Posted

Well it looks like I've got some major problems now. My system seemed fine enough (Win 7 Pentium dual core CPU 3.33 GHz, 4.0GB RAM ATI Radeon HD 43/4500.)

Now after a re-install, the game won't even launch. I get an MLB 2K9 message box saying: "Could not write license data !" "contact customer support" .........

??????????? The game ran and played fine enough until I tried the 2010 roster. Uh oh..... Not sure about what has happened.

Share this post


Link to post
Share on other sites

Posted

Well it looks like I've got some major problems now. My system seemed fine enough (Win 7 Pentium dual core CPU 3.33 GHz, 4.0GB RAM ATI Radeon HD 43/4500.)

Now after a re-install, the game won't even launch. I get an MLB 2K9 message box saying: "Could not write license data !" "contact customer support" .........

??????????? The game ran and played fine enough until I tried the 2010 roster. Uh oh..... Not sure about what has happened.

A roster mod would not cause you to get that error. As the roster is installed in the following (Win7): C:\Users\(User Name)\AppData\Roaming\2K Sports\MLB 2K9\Saves

How did you get this game? Retail boxed version, Digital Download, etc...?

Share this post


Link to post
Share on other sites

Posted

I purchased it new at a retail outlet. I can't under stand how it basically worked fine out of the box and now I'm where I'm at... Maybe 2K10 is not looking like such a bad idea after all...

Share this post


Link to post
Share on other sites

Posted

Could something have gone wrong during uninstall/re-install?

Share this post


Link to post
Share on other sites

Posted

Could something have gone wrong during uninstall/re-install?

Sounds like it. Uninstall again. Before you attempt another re-install, make sure you don't have any background programs running like Anti-V or Firewall. Turn those off during the re-install.

Share this post


Link to post
Share on other sites

Posted

Gotcha. I'm going to try again.

Share this post


Link to post
Share on other sites

Posted

Gotcha. I'm going to try again.

It's old-fashioned, but I'd recommend restarting your computer after uninstalling it again.

Share this post


Link to post
Share on other sites

Posted

Looks like there's a repair feature here so I'm gonna give that a shot first. Don't have much to lose at this point I guess!!

Share this post


Link to post
Share on other sites

Posted

It's old-fashioned, but I'd recommend restarting your computer after uninstalling it again.

DB's right. Windows needs to be re-started sometimes. Get the hampster running again. :fool:

Share this post


Link to post
Share on other sites

Posted

So forget about the repair thing then you think? Just re-start?

Share this post


Link to post
Share on other sites

Posted

So forget about the repair thing then you think? Just re-start?

I forgot about the "Repair" option. Try that first.

Share this post


Link to post
Share on other sites

Posted

It's running now and says its copying new files so let's wait and see...

Share this post


Link to post
Share on other sites

Posted

Well... after uninstalling, re-starting, re-installing,.... NO DICE. Same trouble. Strange though, the C:program files x86 (2Ksports/MLB/2K9) contains all of the game files but the Appdata local/ roaming, does not contain the files that it should. ?????????? Looks like it's gonna be 2K10 or back to PS 09 the show by tonight. Thanks for the helpful advice guys.

Share this post


Link to post
Share on other sites

Posted

Great news! After getting a copy of 2K10 and installing it, I was also able to fix my problems w/ 2K9 and now I have both up and running on my system hassle free. Yahoo! Turns out the error message was due to the Program files x 86 being set to read only. Looking forward to playing some ball now.

Share this post


Link to post
Share on other sites

Posted

Great news! After getting a copy of 2K10 and installing it, I was also able to fix my problems w/ 2K9 and now I have both up and running on my system hassle free. Yahoo! Turns out the error message was due to the Program files x 86 being set to read only. Looking forward to playing some ball now.

Good to hear. :drinks:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0