Welcome to MVP Mods

Welcome to MVP Mods, like most online communities, you must register to view or post in our community, but don't worry, this is a simple, completely free process that requires just some information from you to signup. Be a part of MVP Mods by signing in or creating an account.

  • Get access to over 8,000 modifications for MVP, MLB 2K and High Heat Baseball FOR FREE!
  • Become an amazing part of our online community to discuss baseball!
  • Participate in the Shoutbox on our front page!

indiansjoe

After installing a roster update the game crashes when I try to load into an actual game.

28 posts in this topic

I can play the game just fine vanilla, and it is a physical copy of the game that I had received on Ebay. I can load up the game just fine, look through the rosters, and see that the roster is current to real life. The players have no faces on the roster screen, it is just a silhouette. Whenever I try to play a game, either quick play or dynasty mode, it loads about half the bar and the freezes and crashes. I'm currently trying to load Gordo's "2017 BaseUp! End of Season Rosters - Phase 2." The files in his mod are the only ones that i have attempted installing, and I followed his instructions of deleting the .dat files rather than overwriting. If I am doing something wrong, help would be greatly appreciated.

Share this post


Link to post
Share on other sites
57 minutes ago, Gordo said:

Start with this thread and work your way down.  This has been asked many times.  

http://www.mvpmods.com/forums/topic/58072-playing-mvp-baseball-2005-with-2015-rosters/

 

If you search the word "crash", you'd probably find similar answers.  Bottom line is you cannot simply just drop a new roster set into a vanilla install of MVP.

I can't get the file prjMCP.exe to open after installing mvpedit. I get an error stating "Component 'mscomctl.ocx' or one of its dependencies not correctly registered: a file is missing or invalid".

Edit: I found your post here, and after extracting these files into the mvpedit folder, it still is not working giving me the same error.

Double Edit: I ran it in compatibility mode for windows xp service pack 3 and it opened.

Edited by indiansjoe

Share this post


Link to post
Share on other sites
9 minutes ago, Yankee4Life said:

What are you talking about??

Sorry I have been a bit all over the place. My current stage is I have MVPedit open with the current roster, but I am unsure what to do from here to get my game to start working. According to the post Gordo linked me to I need to change the cyberface numbers to something between 901-915. I have no clue what this means, other than I need to get the rosters open on MVPedit, and change something?

Share this post


Link to post
Share on other sites

Programs sometimes need certain files and drivers to run.  Did you do a site search for "mscomctl" ?  I'll bet you'll find something.

Share this post


Link to post
Share on other sites
6 minutes ago, Gordo said:

Programs sometimes need certain files and drivers to run.  Did you do a site search for "mscomctl" ?  I'll bet you'll find something.

Yeah I managed to get to that point. I put in a screen shot of what I see, what do i need to do next to get the roster to work?

Screenshot_1.png

Share this post


Link to post
Share on other sites
  • Install MVP 2005; patch with official patch 3 only.
  • Make a copy of that entire MVP folder (and keep it to re-copy if you want to do multiple installs of total conversion/classic mods)
  • On the copy, install MVP 15; however, some had trouble with MVP 15 and stability; you can try one of the TC mods prior to 15.
  • Update, minimally, cyberfaces from that date forward.* 
  • Install the 2017 rosters as indicated

Report back what you find.

 

*It's not that the cyberfaces HAVE TO match exactly, but there has to be a cyberface there for the game to read (and it has to be a stable cyberface, which most are. Meaning, if the face numbers don't match what's coded in the roster, this is when you get the Black face on the White player or vice versa.  The only one recently I've found that crashes my game is Max Kepler.

Share this post


Link to post
Share on other sites
1 hour ago, Gordo said:
  • Install MVP 2005; patch with official patch 3 only.
  • Make a copy of that entire MVP folder (and keep it to re-copy if you want to do multiple installs of total conversion/classic mods)
  • On the copy, install MVP 15; however, some had trouble with MVP 15 and stability; you can try one of the TC mods prior to 15.
  • Update, minimally, cyberfaces from that date forward.* 
  • Install the 2017 rosters as indicated

Report back what you find.

 

*It's not that the cyberfaces HAVE TO match exactly, but there has to be a cyberface there for the game to read (and it has to be a stable cyberface, which most are. Meaning, if the face numbers don't match what's coded in the roster, this is when you get the Black face on the White player or vice versa.  The only one recently I've found that crashes my game is Max Kepler.

I am going through your steps, and in the first one, every time I download and use any of the patches, it makes my game play ridiculously fast. Sound is the same, but the animations are like 10x as fast.

Edit: I tried the total conversion for mvp 15, without the patch, and got the same issue that I have been having, where it just crashes after loading halfway

Edited by indiansjoe

Share this post


Link to post
Share on other sites

Just to clarify, any of the Total Classic mods I have installed work just fine, but every total conversion I have tried post year 2005 fails to load. 

Share this post


Link to post
Share on other sites

Try MVP 12 without modding it additionally.  Report back.

Share this post


Link to post
Share on other sites
1 hour ago, Gordo said:

Try MVP 12 without modding it additionally.  Report back.

Same problem as before. Loads halfway and quits.

Edit: I would also like to say thanks for being patient and helping me with all this. I appreciate it greatly.

Edited by indiansjoe

Share this post


Link to post
Share on other sites

2 things:

Check out the first part of this thread and apply it:

Secondly, simply reboot your PC.  For some strange reason after Windows XP, occasionally rebooting my Windows 7 PC can help.

 

Also, see if you get different results in different MLB stadiums.  Don't stray from the basic uniforms.  Anything can cause a crash or a hang.  Isolating it can be a pain in the ass.

Share this post


Link to post
Share on other sites
42 minutes ago, Gordo said:

2 things:

Check out the first part of this thread and apply it:

Secondly, simply reboot your PC.  For some strange reason after Windows XP, occasionally rebooting my Windows 7 PC can help.

 

Also, see if you get different results in different MLB stadiums.  Don't stray from the basic uniforms.  Anything can cause a crash or a hang.  Isolating it can be a pain in the ass.

I applied those methods, and mvp 12 is still not loading games for me. I have tried multiple teams resulting in the same thing of closing out. I just don't understand how the classics are working, but the total conversions aren't. Seems strange to me. The two classic ones I tried were Walk through history, and Negro league, if that helps you determine my issue. 

Share this post


Link to post
Share on other sites

I only have tried a few TC's, but usually without a hitch.  Look through the other crashing threads.   You should be able to run minimally MVP 08 or 12 with no problems on their own.   

Only other thing I can think is right click on the program's .exe file and make sure you have compatibility mode for XP (Sp3) and run as administrator check.   If this doesn't work I'm at a loss.

What is your operating system again?  If you're still monkeying around with Windows 10 and that fix, more power to ya.

Share this post


Link to post
Share on other sites
31 minutes ago, Gordo said:

I only have tried a few TC's, but usually without a hitch.  Look through the other crashing threads.   You should be able to run minimally MVP 08 or 12 with no problems on their own.   

Only other thing I can think is right click on the program's .exe file and make sure you have compatibility mode for XP (Sp3) and run as administrator check.   If this doesn't work I'm at a loss.

What is your operating system again?  If you're still monkeying around with Windows 10 and that fix, more power to ya.

I am running Windows 10, as I got the fix mentioned in that forum thread to work. I would try it on a windows 7 machine, but I do not have access to one, nor can I dual boot since my c: drive doesn't have much space, and my f: drive is set to dynamic.

Share this post


Link to post
Share on other sites

@Gordo I tried running mvp 15 in compatibility and admin mode, and this time the entire bar filled up before crashing. It loaded much further than it ever has before.

Edited by indiansjoe

Share this post


Link to post
Share on other sites

Honestly, I'm not sure what else to tell you.  You're in this Windows 10 environment and the supposed fix.  But, more guys here have had more problems than success.  My last tip would be to get the dual boot going or an alternate PC running W7 or XP.

Share this post


Link to post
Share on other sites
48 minutes ago, Gordo said:

Honestly, I'm not sure what else to tell you.  You're in this Windows 10 environment and the supposed fix.  But, more guys here have had more problems than success.  My last tip would be to get the dual boot going or an alternate PC running W7 or XP.

Well I appreciate you going through so much work to help me out despite us not coming to a solution. Ill still work on getting a dual boot going, or possible playing it through a virtual machine.

Share this post


Link to post
Share on other sites

I know there have been contentions that there are fixes for Windows 10, but obviously they are not complete fixes.  There was something posted about a Links golf file or some such helping the matter but it was never confirmed.  Even the guy who posted the "fix" that you tried admitted it wasn't the best solution and no one else was confirming it was a complete fix....so how good could it have been?

I don't think there is no solution, I think the solution is what I posed all along.  I think you're going to have trouble with the virtual machine.  Good luck.

Share this post


Link to post
Share on other sites
On 26/09/2017 at 8:16 PM, Gordo said:
  • Update, minimally, cyberfaces from that date forward.* 
  • Install the 2017 rosters as indicated

 

When you say to update cyberfaces, do you suggest just going into the cyber section of downloads and getting everything from 2015 forward that has been added? Should I get them from a specific person? Is it really just update all the ones that have come out?

Share this post


Link to post
Share on other sites

Yes, from the date of release of the TC mod forward.  As far as what to choose, check the reviews.

Share this post


Link to post
Share on other sites
2 hours ago, Gordo said:

Yes, from the date of release of the TC mod forward.  As far as what to choose, check the reviews.

Cool, thanks.

Share this post


Link to post
Share on other sites
On 10/2/2017 at 7:52 PM, Gordo said:

Yes, from the date of release of the TC mod forward.  As far as what to choose, check the reviews.

Did exactly that. Got Jed and Jogo's facepacks. Just went with Jed because they looked all round better to me.
Now, I have no crashes, but I did notice that Judge has Papi's face.  I don't see anyone having done a Judge cyber yet, though.

Share this post


Link to post
Share on other sites

It was definitely done somewhere.  Not sure who Jogo is.

Share this post


Link to post
Share on other sites
33 minutes ago, Gordo said:

It was definitely done somewhere.  Not sure who Jogo is.

Sorry not "jogo".  "jogar84" :D

Share this post


Link to post
Share on other sites

Don't always go by the preview pictures.   One thing you can do is make a backup of your models.big file.  Then load in the "suspect" faces and check them out in the manager's section of the game (like in "edit" player....but you're not really editing, just looking).  If you don't like any or all, you can revert to the previous models file.

(btw...you don't always have to quote me if you're responding right underneath..... besides.... no one else talkin right now :) )

Share this post


Link to post
Share on other sites

Posted (edited)

Oh, I know, it's just what I do on forums. I hate reading forums and trying to follow conversations between people and not always knowing who someone is referring to. I'm just obsessive about organisation, that's all. :blush:
I'll go back in and test those other faces, I just basically wanted to see if I was going to get crashes or not. Since it's running smooth I can start adding other stuff so I can play a playoff with this year's teams.

Edited by tinpanalley

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now