Jump to content
Gordo

MVP not starting after Windows 7 9-8-15 Updates

Recommended Posts

Since this was brought up in the shout box, figured we should get a thread going on this in case this turns convoluted.  Kyleb first indicated that MVP won't start after Windows 7 updates were installed from about 9/8/15.  I can confirm this is a problem.  I can also confirm that a barebones install of MVP would not start, nor would it start from an alternate HDD.  I also tried various compatibility modes (W98, XP w/ SP 2, etc.) to no avail.

Seems there were 10 M$ Windows updates labeled either security updates or the generic update:

24uz31c.jpg

It seems there are 40+ Office updates (as I only have the Student edition), though I doubt anything there would have interferred.  Only thing to do is uninstall the updates Windows updates 1 by 1 and see if there's any effect.

 

Addendum:  well after I saw that Windows was going to require me to restart my PC after each uninstall, I decided to delete them all and restart.  After that, MVP DID in fact start up. Now it's a matter of which one of these is the culprit.  Maybe looking at the details of each one would provide a hint, but not holding my breath. Also, my TW08 game did start up before the removal of these, so there's something about MVP it didn't like.

One thing maybe someone can try is to do a fresh MVP install and then maybe move the data sub-folder over from their mod of choice.

 

Addendum 2:  This might be it:   https://support.microsoft.com/en-us/kb/3086255

      From the summary:  In addition to the changes that are listed for the vulnerabilities that are described in Microsoft Security Bulletin MS15-097, this security bulletin addresses a defense-in-depth update for the secdrv.sys driver, a third-party driver. The update turns off the service for the secdrv.sys driver. This may affect the ability to run some older games.

 

Edited by Gordo

Share this post


Link to post
Share on other sites

Thank you SO much for looking into this. I did the registry edit linked in Addendum 2 (copied below), set the driver's service to automatic, then rebooted and it seems to have done the trick. I'll report back if anything wonky pops up. Thanks again!

 

Or, you can edit the registry directly. To do this, follow these steps:

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following subkey in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\secdrv
  3. Right-click Start, and then click Modify.
  4. In the Value data box, do one of the following:
    • Type 4 to disable the driver's service, and then click OK.
    • Type 3 to set the driver's service to manual, and then click OK.
    • Type 2 to set the driver's service to automatic, and then click OK.
  5. Exit Registry Editor.

Share this post


Link to post
Share on other sites

Oh ok, so you kept the update and just did the registry work around?  Because I did the updates but omitted that one security update and the game did work, so that was definitely the culprit.  I'll have to re-DL that 1 update and then try the registry edit and report back.

Share this post


Link to post
Share on other sites

I installed that culprit update and did the registry fix.  Confirming that Kyleb's choice "Type 2 to set the driver's service to automatic, and then click OK" is the one to use.  Rebooting the PC after making this registry change is key.

I would also backup your registry just in case.  You simply right click on "Computer" in the left hand column and select export.  I would suggest naming it something like the date of the backup and regbak or something like that.  It will save it as a reg file to whatever location you choose.

Edited by Gordo

Share this post


Link to post
Share on other sites

Thank you guys so much!!!  I feared that microsoft would put my dynasty out of service..  Im going to do this, see if it works for me.. I have windows 8.1

 

Ok I did the check, changed the number from 4 to 3 and restarted..  I started mvp and got a notice that some features were not permitted or something, and I simply clicked allow access..  The game is loaded, it seems to work fine.. Im off to continue my dynasty...

You guys are awesome, thanks again for this update, Im sure there are some who havnt noticed the microsoft update has shut the game down, and will come looking.

Edited by DeuceBlades

Share this post


Link to post
Share on other sites

1) Run an elevated command prompt from the desktop (by pressing Windows key+X and selecting Command Prompt (Admin))

2) Type in this command:

sc config secdrv start=auto

Try to run MVP after restarting your machine to implement the changes.

Share this post


Link to post
Share on other sites

when mine was on auto it wouldnt run the game at all, because that was the default install from microsoft update, I suggest setting it 3 to where it is manual

 

Edited by DeuceBlades

Share this post


Link to post
Share on other sites

@ leekt :  no, not necessarily.  We're talking about the security updates M$ recently placed on W7.  Read again above to clarify.  If you're not having trouble starting your MVP game on your W7 PC, then either you haven't received/installed the updates yet or you got lucky (somehow). 

You don't need to install individual updates unless that's how you normally do it. 

@ Deuce:  good idea that people try the various options indicated in kyle's posting to see what works for them.  As KC has it, there are command prompts for people who don't like monkeying in their registry.

 

If "Windows key + X" doesn't work for you, type "cmd" in your search window (from the Start button) and right click on "cmd.exe", right click, and choose "run as administrator".  Also, when I tried this initially, the cmd box prompted me to have a space after the "=" sign.

Edited by Gordo

Share this post


Link to post
Share on other sites

The registry edit worked great. You guys are wonders at figuring this stuff out. i thought is was just something wrong with my computer. Thanks for all the help and support you guys give. I feel sorry for the people who don't follow this site. They all probably just threw there discs out the window yesterday.

Share this post


Link to post
Share on other sites

You're very welcome.  You may be right about the discs.  We may see prices come down inadvertently on ebay. ;)

Share this post


Link to post
Share on other sites

The registry edit worked great. You guys are wonders at figuring this stuff out. i thought is was just something wrong with my computer. Thanks for all the help and support you guys give. I feel sorry for the people who don't follow this site. They all probably just threw there discs out the window yesterday.

not if they keep an xp machine just for this game :)

Share this post


Link to post
Share on other sites

This thread suited the needs of this old head EXTREMELY well. I kept running into the brick wall of program death every time I tried to run MVP 05.exe. I just purchased and received a CD version of MVP 2005 and am anxious to get going.  Became a member a while back when I fond this community. The mods are incredible and the advice on here is excellent. The thread above is indicative of the knowledge on display here.

I am fairly decent with all this computer upkeep but those last Windows 7 updates did me in. All is well once again in Clarence, PA.

The Nvidia 960 GTX SSC 4gb card in my machine is gonna dig this game....I can't wait to get this classic running again! Job well done, and YES, this thread is very important moving forward!!!!

 

Now, to go get the first patch for MVP 15 and get it installed. Also, TiT installer is the bomb....you guys have it all covered! Rock on MVPMODS and Lets Go Bucs!

Share this post


Link to post
Share on other sites

Human Stain...now that's a guy that's gonna go places. Certainly a draft pick to watch

I'm informing my scouts to keep a close eye on him. But there is word he may have trouble with the curve.

 

On a serious note, this is why I have stuck with XP for so long. Not knocking new OSs, but it always seems like the more they update them, the more problems they cause for older games. But also on that note, BRAVO gentlemen. Bravo! Well done solving this issue.

Edited by Slydude3129

Share this post


Link to post
Share on other sites

Human Stain is the name of an original song one of my metal bands performs. I just liked it for a moniker. Yes, be sure to track this guy closely...ha ha...

I have another machine with XP on it, but the video card is junk, so....until I update that I am stuck on Windows 7. Everything is working well now and once again thanks for the great information found here. Batters Up!!!

Share this post


Link to post
Share on other sites

If all you need for your XP machine is a decent vid card, you should be able to find a pretty good 4 GB card on ebay for $20 or so.

Share this post


Link to post
Share on other sites

If all you need for your XP machine is a decent vid card, you should be able to find a pretty good 4 GB card on ebay for $20 or so.

I definitely recommend...THE POCKET ROCKET, THE NVIDIA GTX 750Ti, which requires NO ADDITIONAL POWER

sTitYa3.jpg

Share this post


Link to post
Share on other sites

KC...how would one know that that is compatible with their system.  Aren't there certain motherboard and power supply requirements?

Share this post


Link to post
Share on other sites

the 750 ti would be overkill for mvp, especially on an xp machine but it's the best that doesn't require power.  not all video cards need a power supply to them.  you can pretty much use about any video card you find on craigslist for as little as $10 and it'll play mvp just fine.  just about any upgrade over onboard graphics will be more than enough for mvp on an xp build.

Edited by Homer

Share this post


Link to post
Share on other sites

Hello!

I have a trouble.

maybe, this support is useful.

MVP BASEBALL did not start my PC suddenly either.

Similar Security Update is installed.

Should I delete this Security Update?

Or

What should I do?
Explained it in order; when give you it, is support.
My PC is Windows7.

 

access.png

security.png

Share this post


Link to post
Share on other sites

I installed that culprit update and did the registry fix.  Confirming that Kyleb's choice "Type 2 to set the driver's service to automatic, and then click OK" is the one to use.  Rebooting the PC after making this registry change is key.

I would also backup your registry just in case.  You simply right click on "Computer" in the left hand column and select export.  I would suggest naming it something like the date of the backup and regbak or something like that.  It will save it as a reg file to whatever location you choose.

Hey there.  I came over from the other support thread.  I got the 2005 edition of the game to work, but it couldn't load my old owner mode in that.  Would that possibly be because I replaced it with the 2015 mod owner mode?  If so, how do I get the 2015 version to run.  Just to clarify for everyone else on this thread, I installed it in May or June and it's been working perfectly up until the other day.  I have the exact same problem as listed in this thread.

Edited by mrmiller
Missing necessary information

Share this post


Link to post
Share on other sites

mrmiller.... check in your Documents section for the sub-folders for mvp2005 and eamods08.  I think the 2015 TC mod is pulling saves from the eamods08 folder and mvp2005 pulls from the other, so switch what you need.

Share this post


Link to post
Share on other sites

I checked in both documents and program files, but I couldn't find those subfolders.  All of the MVP 15 files seem to be in the right place.  A new problem seems to be that the game crashes when I try to play anything.  I don't know if that's because I moved the files from 2005 into a separate folder elsewhere on my computer because of the addition of the mod.  

 

I did find save game data for MVP2005 in another folder outside of the general MVP Baseball folder.  I don't know if that helps or not.

Share this post


Link to post
Share on other sites

I don't know.  You're confusing me a bit.  "Documents" (which used to be mydocuments) houses the game saves, be they for season, or your options and what not.  We're not talking about the files for the actual game itself (which originally got installed to the Program Files folder).

Share this post


Link to post
Share on other sites

I have an another trouble.

my pc (OS:Windows XP)

Total Classic series are able to play, but

MVP 08~15 are clash, In the middle of a road screen in (the always same place)

Share this post


Link to post
Share on other sites

Okay I see what you mean.  Attached is a diagram of what I have in "documents" right now.  There's no EAmods' MVP 08 though.  I don't remember seeing that for the 2015 mod or the original game when I initially installed it. 

 

However, the question still remains how do I get MVP 15 itself to work.  

 

My apologies for being confusing.  I'm no computer wizard.

 

 

Documents Diagram.png

Share this post


Link to post
Share on other sites

Your MVP Baseball 2015 folder looks as if this is to where you installed the MVP 15 TC mod.  I don't know what the MVP Baseball 2005 data folder is.... it looks like something you've created.

Your "This PC/Documents" location suggests you're on Windows 10.  There are separate threads for Windows 10 and MVP 15 support discussions.  See those.  This thread is for what's in the original post.

Share this post


Link to post
Share on other sites

I'm not on Windows 10.  I have 8.1.  I would've gone to the 10 thread initially if I had it, but I don't.  The only other thing I can think of is if I move the MVP Baseball 15 Folder into the game's program files.

Share this post


Link to post
Share on other sites

Don't move any install once you do install it.  Install to a new location from scratch.  Moving it now will do nothing.

Share this post


Link to post
Share on other sites

So you're saying just do a complete re-install?  I would assume my save game data and owner mode would be able to be important if I find those files, right?

Share this post


Link to post
Share on other sites

Yes.  Provided you want to continue with it.   I would search <*.sav> with no brackets on your entire C drive to see where those saves are located since you can't find them.  If you're search comes through empty, then you really didn't save anything in game. 

You'll wanna take future concerns to the other proper thread at this point.

Share this post


Link to post
Share on other sites
Guest

My windows 7 64 bit machine mustn't be a "magic" machine.  I did EVERYTHING in the #2 addendum and it shows the beginning little pic and then Windows kicks me out and there's NO exception...bare bones install or my 1971 season!!!

What's next guys???

 

BRobby05

Share this post


Link to post
Share on other sites

If this update were the cause, you wouldn't see the pic.   That file was interfering with the game starting entirely.

Share this post


Link to post
Share on other sites
Guest

No, it was the cause because I had been monkeying around with the stuff before I even wrote the above post.  After I had written that I made sure that all the updates had been uninstalled and the regedit was adjusted, I decided to try to uninstall and reinstall the bare bones game and use the patch #2 and I also restored my 1971 season and it works now.  I did notice that when I started to try to reinstall the updates that the sec. update for Power Point dated around Oct. 18th caused a problem that's all so far and I have about 44-46 to go yet.

 

I did notice about 3 weeks ago that the icon for the hex program became a red circle with a white "X" inside.  Does anybody know anything about that.  I uninstalled and reinstalled to no avail.

 

Thanks,

 

BRobby05

Share this post


Link to post
Share on other sites

I think you're getting beyond the scope of this thread.  What hex program are you talking about?  Nothing here about a PPT update or other update problems. Maybe you should take this to the MVP15 or start a new thread so this doesn't get convoluted.

Share this post


Link to post
Share on other sites
Guest

Actually it's the hdd program uploaded from here by Umachines in June 2005.  I was just checking to see why my icon all of a sudden got messed up about the same time as this update thing started.

I only other "update" that messed me up today was W7 64 bit update KB3086255...security update for same.

 

Thanks,

 

BRobby05

Share this post


Link to post
Share on other sites

1st time I've ever posted ... and I just want to say thank you !!!!  Thank you, thank all of you for everything on this site!!!

This is just the latest example of all I am grateful for.  I hadn't played for a while and when the game didn't load, I spend a good 6 hours or so trying to figure out the problem.  I finally did what I should have done in the 1st place and looked in here to see if anyone else was having the same problems and wow... within 2 minutes I had the answer.  You guys are amazing!!!  Tried changing the value in the registry from 4 to 3.. and that was all it took. 

Downloaded the latest seasons I didn't already have and spent the rest of the day playing games with the Milwaukee Braves against the New Your Yankees...  one of my favorite things in the world to do... and impossible to do without all the fantastic, wonderful, marvelous and amazing work that so many of you have contributed to this site.

Thank you again... and bless you all for the 100's of hours of joy I have had because of all you have done!!

GR

Share this post


Link to post
Share on other sites

Hey everyone!

This is my first post here, but firstly I wanted to say how exciting this is to see the game still heavily alive! I put so many hours into it on consoles and still play it frequently. I happened to get lucky and stumble across a PC version at a thrift store today and super stoked to go home and install it. I knew I'd run into problems with the installation since it's such an old game, but I was wondering if someone could help me get it to work.

I followed the instructions on other threads, and through the rabbit hole stumbled across this one and tried the directions in post #2 using all variations still having no luck. I've cleaned install multiple times as well with nothing else but the last patch installed. Every time I try running the game, I get a message to log in with administrative privileges, and when I do that, the game still doesn't boot up. I'm running a 64 bit version of Windows 10 with the very latest Anniversary update that came out the other day. If someone could give a suggestion on what I could try next, I'd greatly appreciate it. It would be fun to experience this with the MVP 2015 mod! Thank you for your help!

Edited by Nesmaster75

Share this post


Link to post
Share on other sites

The problem is with Windows 10.  Check that thread out for the conversation had about it.  My 2c continues being install another HDD  to your PC, install W XP or 7 and run it from there.  I still haven't heard of a consistent, solid W10 workaround as of yet.

Share this post


Link to post
Share on other sites
 

The problem is with Windows 10.  Check that thread out for the conversation had about it.  My 2c continues being install another HDD  to your PC, install W XP or 7 and run it from there.  I still haven't heard of a consistent, solid W10 workaround as of yet.

I have another tower with Windows 7 installed that I'll try my luck on! Thank you for the response, Legend!

Share this post


Link to post
Share on other sites

Fellas,

I am at my wit's end.  I finally got MVP 2005 and purchased Windows 10 to upgrade from 8, using VMWare (I have a Mac).  After fooling with that for hours, I bought Windows 7.  After hours of hiccups, I FINALLY get loaded in.  But now, all that happens is that the game is in demo mode and goes super fast.  It won't allow me to go to the home screen.  I have been messing with this for days.  Does anyone have any solutions?

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×